aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2016-08-28 16:31:16 +0200
committerKatharina Fey <kookie@spacekookie.de>2019-06-04 20:21:03 +0200
commita0f0220726f84dc62f49b593481a00f005e3443e (patch)
tree60417ee05f836c95ad47fcef068ced21f2c59d9a /CMakeLists.txt
parent75481c8cb77067cda4c9fb6499d72764f7e84a24 (diff)
First version of the "eztree" api. It provides more straight-forward ways to use libdyntree (in a less safe way however!)
eztree_* functions do not provide error chec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fd3b8e..5735947 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,10 @@ set(CMAKE_BUILD_TYPE Debug)
# Create our project for further reference
project(libdyntree)
-set(DYN_TREE_SRC lib/dtree.c lib/dyn_utils.c)
+set(DYN_TREE_SRC
+ lib/dtree.c
+ lib/eztree.c
+ lib/dyn_utils.c)
# Define our library in cmake
add_library(libdyntree SHARED ${DYN_TREE_SRC})
@@ -26,7 +29,7 @@ set_target_properties(libdyntree PROPERTIES PREFIX "")
################### TESTING CODE BELOW ###################
-set(TEST_SRC test/main.c include/dtree/eztree.h)
+set(TEST_SRC test/main.c)
add_executable(dyntree_test ${TEST_SRC})
# Library dependencies for the http extention