aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/services/gnome-keyring.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2019-10-05 12:06:29 +0000
committerKatharina Fey <kookie@spacekookie.de>2019-10-05 12:42:50 +0000
commit1148b1d122bc03e9a3665856c9b7bb96bd4e3994 (patch)
tree1a9586de593790e236349d5caa0abdff7f3f6856 /home-manager/modules/services/gnome-keyring.nix
parent919d4e75699aa4ba456fd2d3d416a0522c9c7294 (diff)
parent8bddc1adab0f7a51476f819fa2197353e8e1d136 (diff)
Add 'home-manager/' from commit '8bddc1adab0f7a51476f819fa2197353e8e1d136'
git-subtree-dir: home-manager git-subtree-mainline: 919d4e75699aa4ba456fd2d3d416a0522c9c7294 git-subtree-split: 8bddc1adab0f7a51476f819fa2197353e8e1d136
Diffstat (limited to 'home-manager/modules/services/gnome-keyring.nix')
-rw-r--r--home-manager/modules/services/gnome-keyring.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/home-manager/modules/services/gnome-keyring.nix b/home-manager/modules/services/gnome-keyring.nix
new file mode 100644
index 00000000000..4ca6c7cacf2
--- /dev/null
+++ b/home-manager/modules/services/gnome-keyring.nix
@@ -0,0 +1,55 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+
+ cfg = config.services.gnome-keyring;
+
+in
+
+{
+ meta.maintainers = [ maintainers.rycee ];
+
+ options = {
+ services.gnome-keyring = {
+ enable = mkEnableOption "GNOME Keyring";
+
+ components = mkOption {
+ type = types.listOf (types.enum ["pkcs11" "secrets" "ssh"]);
+ default = [];
+ description = ''
+ The GNOME keyring components to start. If empty then the
+ default set of components will be started.
+ '';
+ };
+ };
+ };
+
+ config = mkIf cfg.enable {
+ systemd.user.services.gnome-keyring = {
+ Unit = {
+ Description = "GNOME Keyring";
+ PartOf = [ "graphical-session-pre.target" ];
+ };
+
+ Service = {
+ ExecStart =
+ let
+ args = concatStringsSep " " (
+ [ "--start" "--foreground" ]
+ ++ optional (cfg.components != []) (
+ "--components=" + concatStringsSep "," cfg.components
+ )
+ );
+ in
+ "${pkgs.gnome3.gnome_keyring}/bin/gnome-keyring-daemon ${args}";
+ Restart = "on-abort";
+ };
+
+ Install = {
+ WantedBy = [ "graphical-session-pre.target" ];
+ };
+ };
+ };
+}