aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2016-08-21 16:59:22 +0200
committerKatharina Fey <kookie@spacekookie.de>2016-08-21 16:59:22 +0200
commitd1f9b84e6926e1f0f1259ec79091873fd221cf01 (patch)
tree7f6a1adedd91eacdecbe5482f133c9d6769a3c10 /CMakeLists.txt
parent98a9a31789203e051404b9bcf2faa29bafd9e4bf (diff)
Adding test file with different test suites (as well as examples).
This should hopefully make it easier to understand the API :)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85eb9af..5f6d416 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ set(CMAKE_BUILD_TYPE Debug)
# Create our project for further reference
project(libdyntree)
-set(DYN_TREE_SRC lib/dyn_tree.c)
+set(DYN_TREE_SRC lib/dyn_tree.c lib/dyn_utils.c)
# Define our library in cmake
add_library(libdyntree SHARED ${DYN_TREE_SRC})
@@ -23,3 +23,11 @@ target_include_directories(libdyntree PRIVATE "lib")
# since the name starts with 'lib' dont add it again
set_target_properties(libdyntree PROPERTIES PREFIX "")
+
+################### TESTING CODE BELOW ###################
+
+set(TEST_SRC test/main.c)
+add_executable(dyntree_test ${TEST_SRC})
+
+# Library dependencies for the http extention
+target_link_libraries(dyntree_test libdyntree) \ No newline at end of file