aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2019-06-04 23:51:12 +0200
committerKatharina Fey <kookie@spacekookie.de>2019-06-04 23:51:12 +0200
commit7df71001ef1a9ea271ae3c409a367d6c2dd628b7 (patch)
treedfd86f523da1d1a8b4e08532a025355d505bc8a3 /CMakeLists.txt
parenta81e5628bd1c855289a6919822cc612a6871b039 (diff)
Changing library name and project structure
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 5 insertions, 31 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc96527..c68025a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,39 +1,13 @@
-############################################
-#
-# libdyntree uses cmake because it's simple
-# Build instructions can be found in the README
-#
-############################################
-
-# Set some flags
cmake_minimum_required(VERSION 2.8.11)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c11")
set(CMAKE_BUILD_TYPE Debug)
-# Create our project for further reference
-project(libdyntree)
-set(DYN_TREE_SRC
- lib/dtree.c
- lib/eztree.c
- lib/dtree_utils.c
-
- # External files compiled in
- lib/jsmn.c)
-
-# Define our library in cmake
-add_library(libdyntree SHARED ${DYN_TREE_SRC})
+project(bowl)
+add_library(bowl SHARED bowl.c)
-# Include the subdirectories to search for headers
-target_include_directories(libdyntree PUBLIC "include")
-target_include_directories(libdyntree PRIVATE "lib")
-
-# since the name starts with 'lib' dont add it again
-set_target_properties(libdyntree PROPERTIES PREFIX "")
+target_include_directories(bowl PUBLIC ".")
################### TESTING CODE BELOW ###################
-set(TEST_SRC test/main.c)
-add_executable(dyntree_test ${TEST_SRC})
-
-# Library dependencies for the http extention
-target_link_libraries(dyntree_test libdyntree) \ No newline at end of file
+add_executable(bowl_test main.c)
+target_link_libraries(bowl_test bowl) \ No newline at end of file