aboutsummaryrefslogtreecommitdiff
path: root/nix/rust.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/rust.nix')
-rw-r--r--nix/rust.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/nix/rust.nix b/nix/rust.nix
new file mode 100644
index 000000000000..5b1dca78f5dc
--- /dev/null
+++ b/nix/rust.nix
@@ -0,0 +1,11 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "rust-devel";
+ buildInputs = with pkgs; [
+ rust-analyzer rustc
+ cargo-watch
+ clangStdenv
+ hello
+ ];
+}