aboutsummaryrefslogtreecommitdiff
path: root/nix/rust.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2021-02-24 17:14:16 +0100
committerKatharina Fey <kookie@spacekookie.de>2021-02-24 17:14:40 +0100
commitf67b7166c621378e87ddc79e1a94e4dfabe412ac (patch)
treed480f75b198a00ec8427e3af2355d3b95cf49bea /nix/rust.nix
parenteffbdeed66e8de8e769b8ac069926ad1a9110e62 (diff)
nix: init default builder directorymain
Diffstat (limited to 'nix/rust.nix')
-rw-r--r--nix/rust.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/nix/rust.nix b/nix/rust.nix
new file mode 100644
index 000000000000..5b1dca78f5dc
--- /dev/null
+++ b/nix/rust.nix
@@ -0,0 +1,11 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "rust-devel";
+ buildInputs = with pkgs; [
+ rust-analyzer rustc
+ cargo-watch
+ clangStdenv
+ hello
+ ];
+}