aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMichael Gattozzi <mgattozzi@gmail.com>2019-11-26 11:08:11 -0500
committerMichael Gattozzi <mgattozzi@gmail.com>2019-11-26 11:08:11 -0500
commitb8635f6a4f2429382fafdbdd1e0b8bb1f8b7b296 (patch)
tree6e59b73f2189c45a4e6000dd5fc619f2da085113 /Cargo.toml
parentbcea608cb4ab1c234f37a6095833f1e916777495 (diff)
Create dev-suite tool to orchestrate tooling
The dev-suite tool acts simmilar to rustup in that it's responsible for keeping the tools up to date, installing the tools, and managing itself. It also includes an init command to run all the various tools init commands all at once. Of course we want what tools people use to be configurable. dev-suite uses dialouger in order to provide a nice text based menu for things like selecting what tools to use etc. Certain functions are stubbed out for now, but they will be expanded over time.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3d82563..2aea2b3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,3 +1,21 @@
+[package]
+name = "dev-suite"
+version = "0.1.0"
+authors = ["Michael Gattozzi <mgattozzi@gmail.com>"]
+edition = "2018"
+
+[[bin]]
+name = "ds"
+path = "src/main.rs"
+
+[dependencies]
+anyhow = "1.0"
+paw = "1.0"
+shared = { path = "shared" }
+structopt = { version = "0.3", features = ["paw"] }
+dialoguer = "0.5"
+which = "3.1"
+
[workspace]
members = [
"shared",