aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMichael Gattozzi <mgattozzi@gmail.com>2020-01-02 11:18:01 -0500
committerMichael Gattozzi <mgattozzi@gmail.com>2020-01-02 11:18:01 -0500
commit1a6669988ab8a896f04c184cd8b4d63f1b3a0c8f (patch)
tree845f70bffca01a6d3d80bb3048efede544fca9db /Cargo.toml
parent86efa907288199acf7bb11ea3f426b18b230a4bd (diff)
Update reqwest and create a release profile
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4132146..356cd9c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ configamajig = { path = "configamajig" }
dialoguer = "0.5"
dirs = "2.0"
paw = "1.0"
-reqwest = { version = "0.10.0-alpha.2", features = ["blocking"] }
+reqwest = { version = "0.10.0", features = ["blocking"] }
shared = { path = "shared" }
structopt = { version = "0.3", features = ["paw"] }
which = "3.1"
@@ -27,3 +27,14 @@ members = [
"ticket",
"hooked",
]
+
+[profile.release]
+opt-level = 3
+debug = false
+rpath = false
+lto = true
+debug-assertions = false
+codegen-units = 1
+panic = 'unwind'
+incremental = false
+overflow-checks = false