aboutsummaryrefslogtreecommitdiff
path: root/lockchain-http/Cargo.toml
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2018-05-08 10:51:57 +0200
committerKatharina Fey <kookie@spacekookie.de>2018-05-08 10:51:57 +0200
commitd4dd69d2f9c430a8f00e1eb7b1c82361caa0b7b4 (patch)
tree4d35ae6f3daf63e23a53f5eb812ca8c77e8a5e8c /lockchain-http/Cargo.toml
parent724018d02d56bbe9ba2ad065cbb595c2cf3df910 (diff)
Adding dependencies to http crate and publishing it
Diffstat (limited to 'lockchain-http/Cargo.toml')
-rw-r--r--lockchain-http/Cargo.toml15
1 files changed, 14 insertions, 1 deletions
diff --git a/lockchain-http/Cargo.toml b/lockchain-http/Cargo.toml
index deb86fd..8fca7d1 100644
--- a/lockchain-http/Cargo.toml
+++ b/lockchain-http/Cargo.toml
@@ -1,6 +1,19 @@
[package]
name = "lockchain-http"
-version = "0.1.0"
+description = "Generic HTTP interface crate for the lockchain ecosystem. Can serve both encrypted and cleartext records"
+version = "0.0.0"
authors = ["Katharina Fey <kookie@spacekookie.de>"]
+documentation = "https://docs.rs/lockchain-http"
+homepage = "https://github.com/spacekookie/lockchain/tree/master/lockchain-http"
+readme = "README.md"
+license = "MIT/X11 OR Apache-2.0"
+
+
[dependencies]
+lockchain-core = "<= 0.3.2"
+
+# Web stack
+gotham = "0.2"
+gotham_derive = "0.2"
+gotham_serde_json_body_parser = "0.2.0" \ No newline at end of file