aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2018-04-02 14:49:27 +0200
committerKatharina Fey <kookie@spacekookie.de>2018-04-02 14:49:27 +0200
commitb52005f49e229e7f69632703e7f152b98ed9988b (patch)
tree571270559832e8a481f7f524cb95539aa1fa26f6 /Cargo.toml
parentc789005d19660f9f56b6eab7090a58758b5c7a07 (diff)
Lots of refactoring
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 5 insertions, 23 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6c442a3..e736320 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,23 +1,5 @@
-[package]
-name = "lockchain-core"
-description = "The core library that handles lockchain vaults and records"
-docs = "https://docs.rs/lockchain-core"
-readme = "README.md"
-version = "0.1.0"
-authors = ["Katharina Fey <kookie@spacekookie.de>"]
-
-[dependencies]
-chrono = { version = "0.4", features = ["serde", "rustc-serialize"] }
-ordermap = "0.3.2"
-
-# Cryptography
-miscreant = "0.3.0"
-base64 = "0.8.0"
-blake2 = "0.7"
-pwhash = "0.1"
-rand = "0.3.0"
-
-# Serialisation
-serde = "1.0"
-serde_json = "1.0"
-serde_derive = "1.0" \ No newline at end of file
+[workspace]
+members = [
+ "lockchain-core",
+ "lockchain-gtk"
+] \ No newline at end of file