summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..232c800
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,13 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "qaul";
+ buildInputs = with pkgs; [
+ rustracer rustup clangStdenv
+
+ cargo-watch
+
+ # Required for the docs
+ mdbook graphviz
+ ];
+}