summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml78
1 files changed, 78 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..2985f19
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,78 @@
+ ❤ (uwu) ~> cd projects/
+ ❤ (uwu) ~> cd projects/
+ ❤ (uwu) ~/projects> git clone https://git.rappet.de/rappet/rustlink
+ ❤ (uwu) ~/projects> git clone https://git.rappet.de/rappet/rustlink
+Cloning into 'rustlink'...
+remote: Enumerating objects: 26, done.
+remote: Counting objects: 100% (26/26), done.
+remote: Compressing objects: 100% (26/26), done.
+remote: Total 26 (delta 6), reused 0 (delta 0)
+Unpacking objects: 100% (26/26), done.
+ ❤ (uwu) ~/projects> rm -rf rustlink/
+ ❤ (uwu) ~/projects> rm -rf rustlink/
+ ❤ (uwu) ~/projects> cargo new
+ ❤ (uwu) ~/projects> cargo new
+error: The following required arguments were not provided:
+ <path>
+
+USAGE:
+ cargo new [OPTIONS] <path>
+
+For more information try - -help
+1(0) ❤ (uwu) ~/projects> cargo new libquassel-protocol
+1(0) ❤ (uwu) ~/projects> cargo new libquassel-protocol
+ Created binary (application) `libquassel-protocol` package
+ ❤ (uwu) ~/projects> git clone https://git.sr.ht/~spacekookie/libquassel
+ ❤ (uwu) ~/projects> git clone https://git.sr.ht/~spacekookie/libquassel
+Cloning into 'libquassel'...
+warning: You appear to have cloned an empty repository.
+ ❤ (uwu) ~/projects> mv libquassel-protocol/ libquassel/protocol
+ ❤ (uwu) ~/projects> mv libquassel-protocol/ libquassel/protocol
+ ❤ (uwu) ~/projects> cd libquassel/
+ ❤ (uwu) ~/projects> cd libquassel/
+ ❤ (uwu) ~/p/libquassel> rm protocol/Cargo.lock
+ ❤ (uwu) ~/p/libquassel> rm protocol/Cargo.lock
+ ❤ (uwu) ~/p/libquassel> cd ..
+ ❤ (uwu) ~/p/libquassel> cd ..
+ ❤ (uwu) ~/projects> cargo build
+ ❤ (uwu) ~/projects> cargo build
+error: could not find `Cargo.toml` in `/home/projects` or any parent directory
+101(0) ❤ (uwu) ~/projects> cd libquassel/
+101(0) ❤ (uwu) ~/projects> cd libquassel/
+ ❤ (uwu) ~/p/libquassel> cargo build
+ ❤ (uwu) ~/p/libquassel> cargo build
+ Updating crates.io index
+ Compiling cfg-if v0.1.10
+ Compiling autocfg v0.1.7
+ Compiling libc v0.2.66
+ Compiling semver-parser v0.7.0
+ Compiling log v0.4.8
+error: linker `cc` not found
+ |
+ = note: No such file or directory (os error 2)
+
+error: aborting due to previous error
+
+error: could not compile `log`.
+warning: build failed, waiting for other jobs to finish...
+error: linker `cc` not found
+ |
+ = note: No such file or directory (os error 2)
+
+error: aborting due to previous error
+
+error: could not compile `libc`.
+warning: build failed, waiting for other jobs to finish...
+error: build failed
+101(0) ❤ (uwu) ~/p/libquassel> cp ../qaul/qaul.net/shell.nix .
+101(0) ❤ (uwu) ~/p/libquassel> cp ../qaul/qaul.net/shell.nix .
+ ❤ (uwu) ~/p/libquassel> cp ../qaul/qaul.net/.envrc .
+ ❤ (uwu) ~/p/libquassel> cp ../qaul/qaul.net/.envrc .
+direnv: error .envrc is blocked. Run `direnv allow` to approve its content.
+ ❤ (uwu) ~/p/libquassel> direnv allow
+ ❤ (uwu) ~/p/libquassel> direnv allow
+direnv: loading .envrc
+Error: the lorri daemon is not running and this project has not yet been evaluated.
+ Please run `lorri daemon`.
+direnv: export +IN_NIX_SHELL
+ ❤ (uwu) ~/p/libquassel> \ No newline at end of file