aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/targets-linux/generic-linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/targets-linux/generic-linux.nix')
-rw-r--r--tests/modules/targets-linux/generic-linux.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/modules/targets-linux/generic-linux.nix b/tests/modules/targets-linux/generic-linux.nix
new file mode 100644
index 00000000000..d9bb85b651a
--- /dev/null
+++ b/tests/modules/targets-linux/generic-linux.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ config = {
+ targets.genericLinux.enable = true;
+
+ nmt.script = ''
+ assertFileExists home-path/etc/profile.d/hm-session-vars.sh
+ assertFileContains \
+ home-path/etc/profile.d/hm-session-vars.sh \
+ 'export XDG_DATA_DIRS="''${NIX_STATE_DIR:-/nix/var/nix}/profiles/default/share:/home/hm-user/.nix-profile/share''${XDG_DATA_DIRS:+:}$XDG_DATA_DIRS"'
+ assertFileContains \
+ home-path/etc/profile.d/hm-session-vars.sh \
+ '. "${pkgs.nix}/etc/profile.d/nix.sh"'
+ '';
+ };
+}