aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/targets-darwin/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/targets-darwin/darwin.nix')
-rw-r--r--tests/modules/targets-darwin/darwin.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/modules/targets-darwin/darwin.nix b/tests/modules/targets-darwin/darwin.nix
new file mode 100644
index 00000000000..511ae87fd98
--- /dev/null
+++ b/tests/modules/targets-darwin/darwin.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+
+ darwinTestApp = pkgs.runCommandLocal "target-darwin-example-app" { } ''
+ mkdir -p $out/Applications
+ touch $out/Applications/example-app
+ '';
+
+in {
+ config = {
+ home.packages = [ darwinTestApp ];
+
+ nmt.script = ''
+ assertFileExists 'home-files/Applications/Home Manager Apps/example-app'
+ '';
+ };
+}