aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/programs/zplug/modules.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/programs/zplug/modules.nix')
-rw-r--r--tests/modules/programs/zplug/modules.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/modules/programs/zplug/modules.nix b/tests/modules/programs/zplug/modules.nix
index 8ebf82b861f..704c5c5e2ef 100644
--- a/tests/modules/programs/zplug/modules.nix
+++ b/tests/modules/programs/zplug/modules.nix
@@ -38,8 +38,10 @@ with lib;
assertFileContains home-files/.zshrc \
'zplug "lib/clipboard", from:oh-my-zsh, if:"[[ $OSTYPE == *darwin* ]]"'
- assertFileRegex home-files/.zshrc \
- '^zplug install$'
+ assertFileContains home-files/.zshrc \
+ 'if ! zplug check; then
+ zplug install
+ fi'
assertFileRegex home-files/.zshrc \
'^zplug load$'