aboutsummaryrefslogtreecommitdiff
path: root/nixos/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/default.nix')
-rw-r--r--nixos/default.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/nixos/default.nix b/nixos/default.nix
new file mode 100644
index 00000000000..d72d8a19557
--- /dev/null
+++ b/nixos/default.nix
@@ -0,0 +1,57 @@
+{ config, lib, pkgs, utils, ... }:
+
+with lib;
+
+let
+
+ cfg = config.home-manager;
+
+ hmModule = types.submodule ({name, ...}: {
+ imports = import ../modules/modules.nix {
+ inherit lib pkgs;
+ nixosSubmodule = true;
+ };
+
+ config = {
+ home.username = config.users.users.${name}.name;
+ home.homeDirectory = config.users.users.${name}.home;
+ };
+ });
+
+in
+
+{
+ options = {
+ home-manager.users = mkOption {
+ type = types.attrsOf hmModule;
+ default = {};
+ description = ''
+ Per-user Home Manager configuration.
+ '';
+ };
+ };
+
+ config = mkIf (cfg.users != {}) {
+ systemd.services = mapAttrs' (username: usercfg:
+ nameValuePair ("home-manager-${utils.escapeSystemdPath username}") {
+ description = "Home Manager environment for ${username}";
+ wantedBy = [ "multi-user.target" ];
+
+ serviceConfig = {
+ User = username;
+ Type = "oneshot";
+ RemainAfterExit = "yes";
+ SyslogIdentifier = "hm-activate-${username}";
+
+ # The activation script is run by a login shell to make sure
+ # that the user is given a sane Nix environment.
+ ExecStart = pkgs.writeScript "activate-${username}" ''
+ #! ${pkgs.stdenv.shell} -el
+ echo Activating home-manager configuration for ${username}
+ exec ${usercfg.home.activationPackage}/activate
+ '';
+ };
+ }
+ ) cfg.users;
+ };
+}