aboutsummaryrefslogtreecommitdiff
path: root/modules/workstation/graphics/i3/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/workstation/graphics/i3/config.nix')
-rw-r--r--modules/workstation/graphics/i3/config.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/modules/workstation/graphics/i3/config.nix b/modules/workstation/graphics/i3/config.nix
index d0732d97360..2a55ab0a8fc 100644
--- a/modules/workstation/graphics/i3/config.nix
+++ b/modules/workstation/graphics/i3/config.nix
@@ -9,7 +9,9 @@
# Use iosevka as default font
fonts = [ "iosevka-term-ss09 10" ];
- keybindings = {
+ keybindings = with pkgs; let
+ gnome-screenshot = "${gnome3.gnome-screenshot}/bin/gnome-screenshot";
+ in {
# Start a terminal
"${modifier}+Return" = "exec ${pkgs.kitty}/bin/kitty";
@@ -75,6 +77,9 @@
"${modifier}+4" = "layout tabbed";
"${modifier}+5" = "layout stacked";
+ # Screenshot shortcut
+ "${modifier}+9" = "exec ${gnome-screenshot} -a";
+
# Do I even use this?!
"${modifier}+Shift+space" = "floating toggle";
"${modifier}+space" = "focus mode_toggle";