aboutsummaryrefslogtreecommitdiff
path: root/modules/targets/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/targets/darwin.nix')
-rw-r--r--modules/targets/darwin.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/targets/darwin.nix b/modules/targets/darwin.nix
new file mode 100644
index 00000000000..0d434234bbb
--- /dev/null
+++ b/modules/targets/darwin.nix
@@ -0,0 +1,14 @@
+{ config, lib, pkgs, ... }:
+
+{
+ config = lib.mkIf pkgs.stdenv.hostPlatform.isDarwin {
+ # Install MacOS applications to the user environment.
+ home.file."Applications/Home Manager Apps".source = let
+ apps = pkgs.buildEnv {
+ name = "home-manager-applications";
+ paths = config.home.packages;
+ pathsToLink = "/Applications";
+ };
+ in "${apps}/Applications";
+ };
+}