aboutsummaryrefslogtreecommitdiff
path: root/modules/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/systemd.nix')
-rw-r--r--modules/systemd.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/modules/systemd.nix b/modules/systemd.nix
index 50bc0e3466f..56164020577 100644
--- a/modules/systemd.nix
+++ b/modules/systemd.nix
@@ -6,8 +6,6 @@ let
cfg = config.systemd.user;
- dag = config.lib.dag;
-
enabled = cfg.services != {}
|| cfg.sockets != {}
|| cfg.targets != {}
@@ -230,7 +228,7 @@ in
# running this from the NixOS module then XDG_RUNTIME_DIR is not
# set and systemd commands will fail. We'll therefore have to
# set it ourselves in that case.
- home.activation.reloadSystemD = dag.entryAfter ["linkGeneration"] (
+ home.activation.reloadSystemD = hm.dag.entryAfter ["linkGeneration"] (
let
autoReloadCmd = ''
${pkgs.ruby}/bin/ruby ${./systemd-activate.rb} \