aboutsummaryrefslogtreecommitdiff
path: root/modules/services/window-managers/xmonad.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/window-managers/xmonad.nix')
-rw-r--r--modules/services/window-managers/xmonad.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/modules/services/window-managers/xmonad.nix b/modules/services/window-managers/xmonad.nix
index 660a609659e..d4643b09168 100644
--- a/modules/services/window-managers/xmonad.nix
+++ b/modules/services/window-managers/xmonad.nix
@@ -1,12 +1,13 @@
{ config, lib, pkgs, ... }:
with lib;
-with import ../../lib/dag.nix { inherit lib; };
let
cfg = config.xsession.windowManager.xmonad;
+ dag = config.lib.dag;
+
xmonad = pkgs.xmonad-with-packages.override {
ghcWithPackages = cfg.haskellPackages.ghcWithPackages;
packages = self:
@@ -90,13 +91,13 @@ in
(mkIf (cfg.config != null) {
home.file.".xmonad/xmonad.hs".source = cfg.config;
- home.activation.checkXmonad = dagEntryBefore [ "linkGeneration" ] ''
+ home.activation.checkXmonad = dag.entryBefore [ "linkGeneration" ] ''
if ! cmp --quiet "${cfg.config}" "$HOME/.xmonad/xmonad.hs"; then
xmonadChanged=1
fi
'';
- home.activation.applyXmonad = dagEntryAfter [ "linkGeneration" ] ''
+ home.activation.applyXmonad = dag.entryAfter [ "linkGeneration" ] ''
if [[ -v xmonadChanged ]]; then
echo "Recompiling xmonad"
${config.xsession.windowManager.command} --recompile