aboutsummaryrefslogtreecommitdiff
path: root/modules/services/status-notifier-watcher.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/status-notifier-watcher.nix')
-rw-r--r--modules/services/status-notifier-watcher.nix36
1 files changed, 17 insertions, 19 deletions
diff --git a/modules/services/status-notifier-watcher.nix b/modules/services/status-notifier-watcher.nix
index 8a2ded8720a..3c3e54877b4 100644
--- a/modules/services/status-notifier-watcher.nix
+++ b/modules/services/status-notifier-watcher.nix
@@ -6,9 +6,7 @@ let
cfg = config.services.status-notifier-watcher;
-in
-
-{
+in {
meta.maintainers = [ maintainers.pltanton ];
options = {
@@ -17,30 +15,30 @@ in
package = mkOption {
default = pkgs.haskellPackages.status-notifier-item;
- defaultText = literalExample "pkgs.haskellPackages.status-notifier-item";
+ defaultText =
+ literalExample "pkgs.haskellPackages.status-notifier-item";
type = types.package;
example = literalExample "pkgs.haskellPackages.status-notifier-item";
- description = "The package to use for the status notifier watcher binary.";
+ description =
+ "The package to use for the status notifier watcher binary.";
};
};
};
config = mkIf cfg.enable {
systemd.user.services.status-notifier-watcher = {
- Unit = {
- Description = "SNI watcher";
- After = [ "graphical-session-pre.target" ];
- PartOf = [ "graphical-session.target" ];
- Before = [ "taffybar.service" ];
- };
-
- Service = {
- ExecStart = "${cfg.package}/bin/status-notifier-watcher";
- };
-
- Install = {
- WantedBy = [ "graphical-session.target" "taffybar.service" ];
- };
+ Unit = {
+ Description = "SNI watcher";
+ After = [ "graphical-session-pre.target" ];
+ PartOf = [ "graphical-session.target" ];
+ Before = [ "taffybar.service" ];
+ };
+
+ Service = { ExecStart = "${cfg.package}/bin/status-notifier-watcher"; };
+
+ Install = {
+ WantedBy = [ "graphical-session.target" "taffybar.service" ];
+ };
};
};
}