aboutsummaryrefslogtreecommitdiff
path: root/modules/services/flameshot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/flameshot.nix')
-rw-r--r--modules/services/flameshot.nix14
1 files changed, 3 insertions, 11 deletions
diff --git a/modules/services/flameshot.nix b/modules/services/flameshot.nix
index 87b494d0fcd..c8659d51d1e 100644
--- a/modules/services/flameshot.nix
+++ b/modules/services/flameshot.nix
@@ -7,16 +7,10 @@ let
cfg = config.services.flameshot;
package = pkgs.flameshot;
-in
-
-{
+in {
meta.maintainers = [ maintainers.hamhut1066 ];
- options = {
- services.flameshot = {
- enable = mkEnableOption "Flameshot";
- };
- };
+ options = { services.flameshot = { enable = mkEnableOption "Flameshot"; }; };
config = mkIf cfg.enable {
home.packages = [ package ];
@@ -33,9 +27,7 @@ in
PartOf = [ "graphical-session.target" ];
};
- Install = {
- WantedBy = [ "graphical-session.target" ];
- };
+ Install = { WantedBy = [ "graphical-session.target" ]; };
Service = {
Environment = "PATH=${config.home.profileDirectory}/bin";