aboutsummaryrefslogtreecommitdiff
path: root/modules/services/flameshot.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /modules/services/flameshot.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to 'modules/services/flameshot.nix')
-rw-r--r--modules/services/flameshot.nix14
1 files changed, 3 insertions, 11 deletions
diff --git a/modules/services/flameshot.nix b/modules/services/flameshot.nix
index 87b494d0fcd..c8659d51d1e 100644
--- a/modules/services/flameshot.nix
+++ b/modules/services/flameshot.nix
@@ -7,16 +7,10 @@ let
cfg = config.services.flameshot;
package = pkgs.flameshot;
-in
-
-{
+in {
meta.maintainers = [ maintainers.hamhut1066 ];
- options = {
- services.flameshot = {
- enable = mkEnableOption "Flameshot";
- };
- };
+ options = { services.flameshot = { enable = mkEnableOption "Flameshot"; }; };
config = mkIf cfg.enable {
home.packages = [ package ];
@@ -33,9 +27,7 @@ in
PartOf = [ "graphical-session.target" ];
};
- Install = {
- WantedBy = [ "graphical-session.target" ];
- };
+ Install = { WantedBy = [ "graphical-session.target" ]; };
Service = {
Environment = "PATH=${config.home.profileDirectory}/bin";