aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/zplug.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/programs/zplug.nix')
-rw-r--r--modules/programs/zplug.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/modules/programs/zplug.nix b/modules/programs/zplug.nix
index 0df395292a7..6cb5e98e313 100644
--- a/modules/programs/zplug.nix
+++ b/modules/programs/zplug.nix
@@ -45,11 +45,14 @@ in {
optionalString (plugin.tags != [ ]) ''
${concatStrings (map (tag: ", ${tag}") plugin.tags)}
''
- }
+ }
'') cfg.plugins)}
''}
- zplug install
+ if ! zplug check; then
+ zplug install
+ fi
+
zplug load
'';