aboutsummaryrefslogtreecommitdiff
path: root/modules/files.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/files.nix')
-rw-r--r--modules/files.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/modules/files.nix b/modules/files.nix
index ac946976faf..11f89963986 100644
--- a/modules/files.nix
+++ b/modules/files.nix
@@ -236,6 +236,9 @@ in
(''
mkdir -p $out
+ # Needed in case /nix is a symbolic link.
+ realOut="$(realpath -m "$out")"
+
function insertFile() {
local source="$1"
local relTarget="$2"
@@ -244,10 +247,10 @@ in
# Figure out the real absolute path to the target.
local target
- target="$(realpath -m "$out/$relTarget")"
+ target="$(realpath -m "$realOut/$relTarget")"
# Target path must be within $HOME.
- if [[ ! $target == $out* ]] ; then
+ if [[ ! $target == $realOut* ]] ; then
echo "Error installing file '$relTarget' outside \$HOME" >&2
exit 1
fi