aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/services/window-managers/i3/i3-followmouse.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/services/window-managers/i3/i3-followmouse.nix')
-rw-r--r--home-manager/tests/modules/services/window-managers/i3/i3-followmouse.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/home-manager/tests/modules/services/window-managers/i3/i3-followmouse.nix b/home-manager/tests/modules/services/window-managers/i3/i3-followmouse.nix
new file mode 100644
index 00000000000..8d51e348877
--- /dev/null
+++ b/home-manager/tests/modules/services/window-managers/i3/i3-followmouse.nix
@@ -0,0 +1,29 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ config = {
+ xsession.windowManager.i3 = {
+ enable = true;
+
+ config.focus.followMouse = false;
+ };
+
+ nixpkgs.overlays = [
+ (self: super: {
+ dmenu = super.dmenu // { outPath = "@dmenu@"; };
+
+ i3 = super.i3 // { outPath = "@i3@"; };
+
+ i3status = super.i3status // { outPath = "@i3status@"; };
+ })
+ ];
+
+ nmt.script = ''
+ assertFileExists home-files/.config/i3/config
+ assertFileContent home-files/.config/i3/config \
+ ${./i3-followmouse-expected.conf}
+ '';
+ };
+}