aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/programs/tmux/emacs-with-plugins.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/programs/tmux/emacs-with-plugins.nix')
-rw-r--r--home-manager/tests/modules/programs/tmux/emacs-with-plugins.nix38
1 files changed, 23 insertions, 15 deletions
diff --git a/home-manager/tests/modules/programs/tmux/emacs-with-plugins.nix b/home-manager/tests/modules/programs/tmux/emacs-with-plugins.nix
index 5e147b7290e..f9bccaa2ce4 100644
--- a/home-manager/tests/modules/programs/tmux/emacs-with-plugins.nix
+++ b/home-manager/tests/modules/programs/tmux/emacs-with-plugins.nix
@@ -2,19 +2,6 @@
with lib;
-let
-
- substituteExpected = path: pkgs.substituteAll {
- src = path;
-
- tmuxplugin_fzf_tmux_url = pkgs.tmuxPlugins.fzf-tmux-url;
- tmuxplugin_logging = pkgs.tmuxPlugins.logging;
- tmuxplugin_prefix_highlight = pkgs.tmuxPlugins.prefix-highlight;
- tmuxplugin_sensible_rtp = pkgs.tmuxPlugins.sensible.rtp;
- };
-
-in
-
{
config = {
programs.tmux = {
@@ -32,10 +19,31 @@ in
];
};
+ nixpkgs.overlays = [
+ (self: super: {
+ tmuxPlugins = super.tmuxPlugins // {
+ fzf-tmux-url = super.tmuxPlugins.fzf-tmux-url // {
+ rtp = "@tmuxplugin_fzf_tmux_url_rtp@";
+ };
+
+ logging = super.tmuxPlugins.logging // {
+ rtp = "@tmuxplugin_logging_rtp@";
+ };
+
+ prefix-highlight = super.tmuxPlugins.prefix-highlight // {
+ rtp = "@tmuxplugin_prefix_highlight_rtp@";
+ };
+
+ sensible = super.tmuxPlugins.sensible // {
+ rtp = "@tmuxplugin_sensible_rtp@";
+ };
+ };
+ })
+ ];
+
nmt.script = ''
assertFileExists home-files/.tmux.conf
- assertFileContent home-files/.tmux.conf \
- ${substituteExpected ./emacs-with-plugins.conf}
+ assertFileContent home-files/.tmux.conf ${./emacs-with-plugins.conf}
'';
};
}