aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix')
-rw-r--r--home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix b/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
index 0f9cfc39a6c..f162a486b8b 100644
--- a/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
+++ b/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
@@ -1,4 +1,4 @@
-{ config, lib, ... }:
+{ config, lib, pkgs, ... }:
with lib;
@@ -20,6 +20,9 @@ with lib;
home.file.result.text = builtins.toJSON
(map (a: a.message) (filter (a: !a.assertion) config.assertions));
+ nixpkgs.overlays =
+ [ (self: super: { rofi = pkgs.writeScriptBin "dummy-rofi" ""; }) ];
+
nmt.script = ''
assertFileContent \
home-files/result \