aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/programs/git-with-str-extra-config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/programs/git-with-str-extra-config.nix')
-rw-r--r--home-manager/tests/modules/programs/git-with-str-extra-config.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/home-manager/tests/modules/programs/git-with-str-extra-config.nix b/home-manager/tests/modules/programs/git-with-str-extra-config.nix
new file mode 100644
index 00000000000..734c5ee764c
--- /dev/null
+++ b/home-manager/tests/modules/programs/git-with-str-extra-config.nix
@@ -0,0 +1,22 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ config = {
+ programs.git = {
+ enable = true;
+ extraConfig = ''
+ This can be anything.
+ '';
+ userEmail = "user@example.org";
+ userName = "John Doe";
+ };
+
+ nmt.script = ''
+ assertFileExists home-files/.config/git/config
+ assertFileContent home-files/.config/git/config \
+ ${./git-with-str-extra-config-expected.conf}
+ '';
+ };
+}