aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/programs/getmail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/programs/getmail.nix')
-rw-r--r--home-manager/tests/modules/programs/getmail.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/home-manager/tests/modules/programs/getmail.nix b/home-manager/tests/modules/programs/getmail.nix
new file mode 100644
index 00000000000..12806c25679
--- /dev/null
+++ b/home-manager/tests/modules/programs/getmail.nix
@@ -0,0 +1,26 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ imports = [ ../accounts/email-test-accounts.nix ];
+
+ config = {
+ home.username = "hm-user";
+ home.homeDirectory = "/home/hm-user";
+
+ accounts.email.accounts = {
+ "hm@example.com".getmail = {
+ enable = true;
+ mailboxes = ["INBOX" "Sent" "Work"];
+ destinationCommand = "/bin/maildrop";
+ delete = false;
+ };
+ };
+
+ nmt.script = ''
+ assertFileExists home-files/.getmail/getmailhm@example.com
+ assertFileContent home-files/.getmail/getmailhm@example.com ${./getmail-expected.conf}
+ '';
+ };
+}