aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix')
-rw-r--r--home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix b/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
new file mode 100644
index 00000000000..b7eb3decebb
--- /dev/null
+++ b/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ config = {
+ home.stateVersion = "19.09";
+
+ home.homeDirectory = "/test-home";
+
+ home.keyboard = {
+ options = [ "ctrl:nocaps" "altwin:no_win" ];
+ };
+
+ xsession = {
+ enable = true;
+ windowManager.command = "window manager command";
+ importedVariables = [ "EXTRA_IMPORTED_VARIABLE" ];
+ initExtra = "init extra commands";
+ profileExtra = "profile extra commands";
+ };
+
+ nmt.script = ''
+ assertFileExists home-files/.config/systemd/user/setxkbmap.service
+ assertFileContent \
+ home-files/.config/systemd/user/setxkbmap.service \
+ ${pkgs.substituteAll {
+ src = ./keyboard-without-layout-expected.service;
+ inherit (pkgs.xorg) setxkbmap;
+ }}
+ '';
+ };
+}