aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/files/source-with-spaces.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/files/source-with-spaces.nix')
-rw-r--r--home-manager/tests/modules/files/source-with-spaces.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/home-manager/tests/modules/files/source-with-spaces.nix b/home-manager/tests/modules/files/source-with-spaces.nix
new file mode 100644
index 00000000000..1d593c64256
--- /dev/null
+++ b/home-manager/tests/modules/files/source-with-spaces.nix
@@ -0,0 +1,20 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ config = {
+ home.file."source with spaces!".source = ./. + "/source with spaces!";
+
+ nmt.script = ''
+ assertFileExists 'home-files/source with spaces!';
+ assertFileContent 'home-files/source with spaces!' \
+ ${
+ builtins.path {
+ path = ./. + "/source with spaces!";
+ name = "source-with-spaces-expected";
+ }
+ }
+ '';
+ };
+}