aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/accounts/email-test-accounts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/accounts/email-test-accounts.nix')
-rw-r--r--home-manager/tests/modules/accounts/email-test-accounts.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/home-manager/tests/modules/accounts/email-test-accounts.nix b/home-manager/tests/modules/accounts/email-test-accounts.nix
new file mode 100644
index 00000000000..9c9c90cf8fe
--- /dev/null
+++ b/home-manager/tests/modules/accounts/email-test-accounts.nix
@@ -0,0 +1,27 @@
+{ ... }:
+
+{
+ accounts.email = {
+ maildirBasePath = "Mail";
+
+ accounts = {
+ "hm@example.com" = {
+ address = "hm@example.com";
+ userName = "home.manager";
+ realName = "H. M. Test";
+ passwordCommand = "password-command";
+ imap.host = "imap.example.com";
+ smtp.host = "smtp.example.com";
+ };
+
+ hm-account = {
+ address = "hm@example.org";
+ userName = "home.manager.jr";
+ realName = "H. M. Test Jr.";
+ passwordCommand = "password-command 2";
+ imap.host = "imap.example.org";
+ smtp.host = "smtp.example.org";
+ };
+ };
+ };
+}