aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/default.nix')
-rw-r--r--home-manager/tests/default.nix54
1 files changed, 51 insertions, 3 deletions
diff --git a/home-manager/tests/default.nix b/home-manager/tests/default.nix
index 49c27239730..a4a4da0c94c 100644
--- a/home-manager/tests/default.nix
+++ b/home-manager/tests/default.nix
@@ -7,14 +7,26 @@ let
nmt = pkgs.fetchFromGitLab {
owner = "rycee";
repo = "nmt";
- rev = "6f866d1acb89fa15cd3b62baa052deae1f685c0c";
- sha256 = "1qr1shhapjn4nnd4k6hml69ri8vgz4l8lakjll5hc516shs9a9nn";
+ rev = "8e130d655ec396ce165763c95bbf4ac429810ca8";
+ sha256 = "1jbljr06kg1ycdn24hj8xap16axq11rhb6hm4949fz48n57pwwps";
};
modules = import ../modules/modules.nix {
inherit lib pkgs;
check = false;
- };
+ } ++ [
+ {
+ # Fix impurities. Without these some of the user's environment
+ # will leak into the tests through `builtins.getEnv`.
+ xdg.enable = true;
+ home.username = "hm-user";
+ home.homeDirectory = "/home/hm-user";
+
+ # Avoid including documentation since this will cause
+ # unnecessary rebuilds of the tests.
+ manual.manpages.enable = false;
+ }
+ ];
in
@@ -27,28 +39,64 @@ import nmt {
./modules/home-environment
./modules/misc/fontconfig
./modules/programs/alacritty
+ ./modules/programs/alot
+ ./modules/programs/aria2
./modules/programs/bash
./modules/programs/browserpass
+ ./modules/programs/dircolors
+ ./modules/programs/direnv
+ ./modules/programs/fish
./modules/programs/git
./modules/programs/gpg
+ ./modules/programs/i3status
+ ./modules/programs/kakoune
+ ./modules/programs/lf
+ ./modules/programs/lieer
+ ./modules/programs/man
./modules/programs/mbsync
+ ./modules/programs/ncmpcpp
+ ./modules/programs/ne
./modules/programs/neomutt
./modules/programs/newsboat
+ ./modules/programs/nushell
+ ./modules/programs/qutebrowser
./modules/programs/readline
+ ./modules/programs/powerline-go
./modules/programs/ssh
+ ./modules/programs/starship
./modules/programs/texlive
./modules/programs/tmux
+ ./modules/programs/vscode
+ ./modules/programs/zplug
./modules/programs/zsh
./modules/xresources
+ ] ++ lib.optionals pkgs.stdenv.hostPlatform.isDarwin [
+ ./modules/targets-darwin
] ++ lib.optionals pkgs.stdenv.hostPlatform.isLinux [
+ ./meta # Suffices to run on one platform.
+ ./modules/misc/debug
+ ./modules/misc/numlock
./modules/misc/pam
./modules/misc/xdg
./modules/misc/xsession
+ ./modules/programs/abook
+ ./modules/programs/autorandr
+ ./modules/services/dropbox
+ ./modules/services/emacs
+ ./modules/services/dropbox
./modules/programs/firefox
./modules/programs/getmail
+ ./modules/services/lieer
+ ./modules/programs/ncmpcpp-linux
./modules/programs/rofi
+ ./modules/programs/waybar
+ ./modules/services/kanshi
+ ./modules/services/polybar
./modules/services/sxhkd
+ ./modules/services/fluidsynth
./modules/services/window-managers/i3
+ ./modules/services/window-managers/sway
./modules/systemd
+ ./modules/targets-linux
]);
}