aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/systemd.nix')
-rw-r--r--home-manager/modules/systemd.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/home-manager/modules/systemd.nix b/home-manager/modules/systemd.nix
index 56164020577..66fffadf737 100644
--- a/home-manager/modules/systemd.nix
+++ b/home-manager/modules/systemd.nix
@@ -228,7 +228,7 @@ in
# running this from the NixOS module then XDG_RUNTIME_DIR is not
# set and systemd commands will fail. We'll therefore have to
# set it ourselves in that case.
- home.activation.reloadSystemD = hm.dag.entryAfter ["linkGeneration"] (
+ home.activation.reloadSystemd = hm.dag.entryAfter ["linkGeneration"] (
let
autoReloadCmd = ''
${pkgs.ruby}/bin/ruby ${./systemd-activate.rb} \
@@ -249,7 +249,7 @@ in
if [[ $systemdStatus == 'running' || $systemdStatus == 'degraded' ]]; then
if [[ $systemdStatus == 'degraded' ]]; then
warnEcho "The user systemd session is degraded:"
- ${systemctl} --user --state=failed
+ ${systemctl} --user --no-pager --state=failed
warnEcho "Attempting to reload services anyway..."
fi