aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/services/unison.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/services/unison.nix')
-rw-r--r--home-manager/modules/services/unison.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/home-manager/modules/services/unison.nix b/home-manager/modules/services/unison.nix
index 93c59e8fd62..a9cf23fb66e 100644
--- a/home-manager/modules/services/unison.nix
+++ b/home-manager/modules/services/unison.nix
@@ -60,7 +60,7 @@ let
};
};
- serialiseArg = key: val: "-${key}=${escapeShellArg val}";
+ serialiseArg = key: val: escapeShellArg "-${key}=${escape [ "=" ] val}";
serialiseArgs = args: concatStringsSep " " (mapAttrsToList serialiseArg args);