aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/services/status-notifier-watcher.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/services/status-notifier-watcher.nix')
-rw-r--r--home-manager/modules/services/status-notifier-watcher.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/home-manager/modules/services/status-notifier-watcher.nix b/home-manager/modules/services/status-notifier-watcher.nix
index 3c3e54877b4..ed0537e22e1 100644
--- a/home-manager/modules/services/status-notifier-watcher.nix
+++ b/home-manager/modules/services/status-notifier-watcher.nix
@@ -34,7 +34,14 @@ in {
Before = [ "taffybar.service" ];
};
- Service = { ExecStart = "${cfg.package}/bin/status-notifier-watcher"; };
+ Service = {
+ ExecStart = "${cfg.package}/bin/status-notifier-watcher";
+ # Delay the unit start a bit to allow the program to get fully
+ # set up before letting dependent services start. This is
+ # brittle and a better solution using, e.g., `BusName=` might
+ # be possible.
+ ExecStartPost = "${pkgs.coreutils}/bin/sleep 1";
+ };
Install = {
WantedBy = [ "graphical-session.target" "taffybar.service" ];