aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/services/lorri.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/services/lorri.nix')
-rw-r--r--home-manager/modules/services/lorri.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/home-manager/modules/services/lorri.nix b/home-manager/modules/services/lorri.nix
index 3b2c244e3c0..6183699088b 100644
--- a/home-manager/modules/services/lorri.nix
+++ b/home-manager/modules/services/lorri.nix
@@ -9,10 +9,19 @@ let
in {
meta.maintainers = [ maintainers.gerschtli ];
- options = { services.lorri.enable = mkEnableOption "lorri build daemon"; };
+ options.services.lorri = {
+ enable = mkEnableOption "lorri build daemon";
+
+ package = mkOption {
+ type = types.package;
+ default = pkgs.lorri;
+ defaultText = literalExample "pkgs.lorri";
+ description = "Which lorri package to install.";
+ };
+ };
config = mkIf cfg.enable {
- home.packages = [ pkgs.lorri ];
+ home.packages = [ cfg.package ];
systemd.user = {
services.lorri = {
@@ -24,7 +33,7 @@ in {
};
Service = {
- ExecStart = "${pkgs.lorri}/bin/lorri daemon";
+ ExecStart = "${cfg.package}/bin/lorri daemon";
PrivateTmp = true;
ProtectSystem = "strict";
ProtectHome = "read-only";
@@ -32,7 +41,7 @@ in {
Environment = let
path = with pkgs;
makeSearchPath "bin" [ nix gitMinimal gnutar gzip ];
- in "PATH=${path}";
+ in [ "PATH=${path}" ];
};
};