aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/services/kdeconnect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/services/kdeconnect.nix')
-rw-r--r--home-manager/modules/services/kdeconnect.nix25
1 files changed, 11 insertions, 14 deletions
diff --git a/home-manager/modules/services/kdeconnect.nix b/home-manager/modules/services/kdeconnect.nix
index bd698fcf836..82de1f0eb7c 100644
--- a/home-manager/modules/services/kdeconnect.nix
+++ b/home-manager/modules/services/kdeconnect.nix
@@ -7,9 +7,7 @@ let
cfg = config.services.kdeconnect;
package = pkgs.kdeconnect;
-in
-
-{
+in {
meta.maintainers = [ maintainers.adisbladis ];
options = {
@@ -31,14 +29,13 @@ in
systemd.user.services.kdeconnect = {
Unit = {
- Description = "Adds communication between your desktop and your smartphone";
+ Description =
+ "Adds communication between your desktop and your smartphone";
After = [ "graphical-session-pre.target" ];
PartOf = [ "graphical-session.target" ];
};
- Install = {
- WantedBy = [ "graphical-session.target" ];
- };
+ Install = { WantedBy = [ "graphical-session.target" ]; };
Service = {
Environment = "PATH=${config.home.profileDirectory}/bin";
@@ -52,16 +49,16 @@ in
systemd.user.services.kdeconnect-indicator = {
Unit = {
Description = "kdeconnect-indicator";
- After = [ "graphical-session-pre.target"
- "polybar.service"
- "taffybar.service"
- "stalonetray.service" ];
+ After = [
+ "graphical-session-pre.target"
+ "polybar.service"
+ "taffybar.service"
+ "stalonetray.service"
+ ];
PartOf = [ "graphical-session.target" ];
};
- Install = {
- WantedBy = [ "graphical-session.target" ];
- };
+ Install = { WantedBy = [ "graphical-session.target" ]; };
Service = {
Environment = "PATH=${config.home.profileDirectory}/bin";