aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/services/imapnotify-accounts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/services/imapnotify-accounts.nix')
-rw-r--r--home-manager/modules/services/imapnotify-accounts.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/home-manager/modules/services/imapnotify-accounts.nix b/home-manager/modules/services/imapnotify-accounts.nix
new file mode 100644
index 00000000000..1c780bf28c3
--- /dev/null
+++ b/home-manager/modules/services/imapnotify-accounts.nix
@@ -0,0 +1,30 @@
+{ lib, ... }:
+
+with lib;
+
+{
+ options.imapnotify = {
+ enable = mkEnableOption "imapnotify";
+
+ onNotify = mkOption {
+ type = with types; either str (attrsOf str);
+ default = "";
+ example = "\${pkgs.isync}/bin/mbsync test-%s";
+ description = "Shell commands to run on any event.";
+ };
+
+ onNotifyPost = mkOption {
+ type = with types; either str (attrsOf str);
+ default = "";
+ example = { mail = "\${pkgs.notmuch}/bin/notmuch new && \${pkgs.libnotify}/bin/notify-send 'New mail arrived'"; };
+ description = "Shell commands to run after onNotify event.";
+ };
+
+ boxes = mkOption {
+ type = types.listOf types.str;
+ default = [];
+ example = [ "Inbox" "[Gmail]/MyLabel" ];
+ description = "IMAP folders to watch.";
+ };
+ };
+}