aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/programs/zathura.nix')
-rw-r--r--home-manager/modules/programs/zathura.nix61
1 files changed, 61 insertions, 0 deletions
diff --git a/home-manager/modules/programs/zathura.nix b/home-manager/modules/programs/zathura.nix
new file mode 100644
index 00000000000..f01bd501c39
--- /dev/null
+++ b/home-manager/modules/programs/zathura.nix
@@ -0,0 +1,61 @@
+{ config, lib, pkgs, ...}:
+
+with lib;
+
+let
+
+ cfg = config.programs.zathura;
+
+ formatLine = n: v:
+ let
+ formatValue = v:
+ if isBool v then (if v then "true" else "false")
+ else toString v;
+ in
+ "set ${n}\t\"${formatValue v}\"";
+
+in
+
+{
+ meta.maintainers = [ maintainers.rprospero ];
+
+ options.programs.zathura = {
+ enable = mkEnableOption ''
+ Zathura, a highly customizable and functional document viewer
+ focused on keyboard interaction'';
+
+ options = mkOption {
+ default = {};
+ type = with types; attrsOf (either str (either bool int));
+ description = ''
+ Add <option>:set</option> command options to zathura and make
+ them permanent. See
+ <citerefentry>
+ <refentrytitle>zathurarc</refentrytitle>
+ <manvolnum>5</manvolnum>
+ </citerefentry>
+ for the full list of options.
+ '';
+ example = { default-bg = "#000000"; default-fg = "#FFFFFF"; };
+ };
+
+ extraConfig = mkOption {
+ type = types.lines;
+ default = "";
+ description = ''
+ Additional commands for zathura that will be added to the
+ <filename>zathurarc</filename> file.
+ '';
+ };
+ };
+
+ config = mkIf cfg.enable {
+ home.packages = [ pkgs.zathura ];
+
+ xdg.configFile."zathura/zathurarc".text =
+ concatStringsSep "\n" ([]
+ ++ optional (cfg.extraConfig != "") cfg.extraConfig
+ ++ mapAttrsToList formatLine cfg.options
+ ) + "\n";
+ };
+}