aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/bat.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/programs/bat.nix')
-rw-r--r--home-manager/modules/programs/bat.nix29
1 files changed, 25 insertions, 4 deletions
diff --git a/home-manager/modules/programs/bat.nix b/home-manager/modules/programs/bat.nix
index aa0df9abd45..e2b30ea9333 100644
--- a/home-manager/modules/programs/bat.nix
+++ b/home-manager/modules/programs/bat.nix
@@ -24,14 +24,35 @@ in {
'';
};
+ themes = mkOption {
+ type = types.attrsOf types.lines;
+ default = { };
+ example = literalExample ''
+ {
+ dracula = builtins.readFile (pkgs.fetchFromGitHub {
+ owner = "dracula";
+ repo = "sublime"; # Bat uses sublime syntax for its themes
+ rev = "26c57ec282abcaa76e57e055f38432bd827ac34e";
+ sha256 = "019hfl4zbn4vm4154hh3bwk6hm7bdxbr1hdww83nabxwjn99ndhv";
+ } + "/Dracula.tmTheme");
+ }
+ '';
+ description = ''
+ Additional themes to provide.
+ '';
+ };
+
};
config = mkIf cfg.enable {
home.packages = [ pkgs.bat ];
- xdg.configFile."bat/config" = mkIf (cfg.config != { }) {
- text = concatStringsSep "\n"
- (mapAttrsToList (n: v: ''--${n}="${v}"'') cfg.config);
- };
+ xdg.configFile = mkMerge ([{
+ "bat/config" = mkIf (cfg.config != { }) {
+ text = concatStringsSep "\n"
+ (mapAttrsToList (n: v: ''--${n}="${v}"'') cfg.config);
+ };
+ }] ++ flip mapAttrsToList cfg.themes
+ (name: body: { "bat/themes/${name}.tmTheme" = { text = body; }; }));
};
}