aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/bash.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/programs/bash.nix')
-rw-r--r--home-manager/modules/programs/bash.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/home-manager/modules/programs/bash.nix b/home-manager/modules/programs/bash.nix
index 82a9fbe8f8b..45fe368bddc 100644
--- a/home-manager/modules/programs/bash.nix
+++ b/home-manager/modules/programs/bash.nix
@@ -82,7 +82,12 @@ in
shellAliases = mkOption {
default = {};
type = types.attrsOf types.str;
- example = { ll = "ls -l"; ".." = "cd .."; };
+ example = literalExample ''
+ {
+ ll = "ls -l";
+ ".." = "cd ..";
+ }
+ '';
description = ''
An attribute set that maps aliases (the top level attribute names in
this option) to command strings or directly to build outputs.
@@ -171,10 +176,10 @@ in
${aliasesStr}
- ${cfg.initExtra}
-
${optionalString cfg.enableAutojump
". ${pkgs.autojump}/share/autojump/autojump.bash"}
+
+ ${cfg.initExtra}
fi
'';