aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/misc/version.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/misc/version.nix')
-rw-r--r--home-manager/modules/misc/version.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/home-manager/modules/misc/version.nix b/home-manager/modules/misc/version.nix
new file mode 100644
index 00000000000..18bb28f7603
--- /dev/null
+++ b/home-manager/modules/misc/version.nix
@@ -0,0 +1,24 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ options = {
+ home.stateVersion = mkOption {
+ type = types.enum [ "18.09" "19.03" "19.09" ];
+ default = "18.09";
+ description = ''
+ It is occasionally necessary for Home Manager to change
+ configuration defaults in a way that is incompatible with
+ stateful data. This could, for example, include switching the
+ default data format or location of a file.
+ </para><para>
+ The <emphasis>state version</emphasis> indicates which default
+ settings are in effect and will therefore help avoid breaking
+ program configurations. Switching to a higher state version
+ typically requires performing some manual steps, such as data
+ conversion or moving files.
+ '';
+ };
+ };
+}