aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/misc/news.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/misc/news.nix')
-rw-r--r--home-manager/modules/misc/news.nix357
1 files changed, 356 insertions, 1 deletions
diff --git a/home-manager/modules/misc/news.nix b/home-manager/modules/misc/news.nix
index 6b01617fc55..b031af99685 100644
--- a/home-manager/modules/misc/news.nix
+++ b/home-manager/modules/misc/news.nix
@@ -452,7 +452,7 @@ in
{
time = "2017-12-11T17:23:12+00:00";
- condition = config.home.activation ? reloadSystemD;
+ condition = config.home.activation ? reloadSystemd;
message = ''
The Boolean option 'systemd.user.startServices' is now
available. When enabled the current naive systemd unit
@@ -1318,6 +1318,361 @@ in
A new module is available: 'programs.neomutt'.
'';
}
+
+ {
+ time = "2020-02-23T10:19:48+00:00";
+ message = ''
+ A new module is available: 'programs.kitty'.
+ '';
+ }
+
+ {
+ time = "2020-02-26T21:20:55+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'wayland.windowManager.sway'
+ '';
+ }
+
+ {
+ time = "2020-03-04T18:55:03+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'programs.abook'
+ '';
+ }
+
+ {
+ time = "2020-03-07T11:43:26+00:00";
+ condition = config.programs.fish.enable;
+ message = ''
+ The option 'programs.fish.functions' has been reworked in
+ order to support all available flags, such as
+ '--description', '--on-event', and more.
+ '';
+ }
+
+ {
+ time = "2020-03-07T13:11:43+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ The NixOS module has a new option: 'home-manager.useGlobalPkgs'.
+
+ This enables using the system configuration's 'pkgs'
+ argument in Home Manager.
+
+ To learn more, see the installation section of the manual
+
+ https://rycee.gitlab.io/home-manager/#sec-install-nixos-module
+ '';
+ }
+
+ {
+ time = "2020-03-07T14:12:50+00:00";
+ message = ''
+ A new module is available: 'programs.lieer'.
+ '';
+ }
+
+ {
+ time = "2020-03-07T14:12:50+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'services.lieer'.
+ '';
+ }
+
+ {
+ time = "2020-03-15T16:55:28+00:00";
+ condition = config.programs.firefox.enable;
+ message = ''
+ In anticipation of Firefox dropping support for extension
+ sideloading[1], we now install extensions directly to
+ Firefox profiles managed through Home Manager's
+
+ 'programs.firefox.profiles'
+
+ option.
+
+ Unfortunately this will most likely trigger an "Existing
+ file is in the way" error when activating your configuration
+ since Firefox keeps a copy of the add-on in the location
+ Home Manager wants to overwrite. If this is the case, remove
+ the listed '.xpi' files and try again.
+
+ This change also means that extensions installed through
+ Home Manager may disappear from unmanaged profiles in future
+ Firefox releases.
+
+ [1] https://blog.mozilla.org/addons/2019/10/31/firefox-to-discontinue-sideloaded-extensions/
+ '';
+ }
+
+ {
+ time = "2020-03-17T21:56:26+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'services.keynav'.
+ '';
+ }
+
+ {
+ time = "2020-03-24T22:17:20+00:00";
+ condition = config.services.compton.enable;
+ message = ''
+ The 'services.compton' module has been deprecated and
+ instead the new module 'services.picom' should be used. This
+ is because Nixpkgs no longer packages compton, and instead
+ packages the (mostly) compatible fork called picom.
+
+ The 'services.compton' and 'services.picom' modules have a
+ few differences:
+
+ - 'services.picom' has a new 'experimentalBackends'
+ option.
+
+ - 'vSync' is now a boolean value on 'services.picom', as
+ opposed to the string in 'services.compton'.
+
+ Migrating to the new picom service is simple - just change
+ all references to 'services.compton' to 'services.picom',
+ and adhere to the above changes.
+
+ The deprecated 'services.compton' will eventually be removed
+ in the future. Please update your configurations to use
+ 'services.picom' as soon as possible.
+ '';
+ }
+
+ {
+ time = "2020-04-08T09:33:05+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'targets.genericLinux'.
+
+ When enabled, this module will configure various settings
+ and environment variables to make Home Manager and programs
+ installed through Nix work better on GNU/Linux distributions
+ other than NixOS.
+
+ It should not be enabled if your Home Manager configuration
+ is deployed on a NixOS host.
+ '';
+ }
+
+ {
+ time = "2020-04-08T11:51:15+00:00";
+ message = ''
+ A new module is available: 'programs.qutebrowser'
+ '';
+ }
+
+ {
+ time = "2020-04-09T09:19:38+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'services.mako'
+ '';
+ }
+
+ {
+ time = "2020-04-23T19:45:26+00:00";
+ message = ''
+ A new module is available: 'programs.lf'
+ '';
+ }
+
+ {
+ time = "2020-04-26T13:46:28+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'services.pulseeffects'
+ '';
+ }
+
+ {
+ time = "2020-05-03T11:13:07+00:00";
+ message = ''
+ A new module is available: 'programs.i3status'
+ '';
+ }
+
+ {
+ time = "2020-05-03T11:21:42+00:00";
+ message = ''
+ A new module is available: 'programs.aria2'
+ '';
+ }
+
+ {
+ time = "2020-05-04T21:19:43+00:00";
+ condition = config.programs.git.enable;
+ message = ''
+ The Git module now supports the 'delta' syntax highlighter.
+
+ It can be enabled through the option 'programs.git.delta.enable'.
+ '';
+ }
+
+ {
+ time = "2020-05-12T20:09:54+00:00";
+ message = ''
+ A new module is available: 'programs.dircolors'
+ '';
+ }
+
+ {
+ time = "2020-05-26T17:13:58+00:00";
+ message = ''
+ A new module is available: 'programs.zoxide'
+ '';
+ }
+
+ {
+ time = "2020-06-03T17:46:11+00:00";
+ condition = config.programs.ssh.enable;
+ message = ''
+ The ssh module now supports the 'ServerAliveCountMax' option
+ both globally through
+
+ programs.ssh.serverAliveCountMax
+
+ and per match blocks
+
+ programs.ssh.matchBlocks.<name>.serverAliveCountMax
+ '';
+ }
+
+ {
+ time = "2020-06-11T18:06:37+00:00";
+ condition = hostPlatform.isLinux && config.services.emacs.enable;
+ message = ''
+ The Emacs service now supports systemd socket activation.
+
+ It can be enabled through the option 'services.emacs.socketActivation.enable'.
+ '';
+ }
+
+ {
+ time = "2020-06-12T17:48:01+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'services.clipmenu'
+ '';
+ }
+
+ {
+ time = "2020-06-12T07:08:09+00:00";
+ condition = config.programs.bash.enable;
+ message = ''
+ A new module is available: 'programs.powerline-go'
+ '';
+ }
+
+ {
+ time = "2020-06-14T13:30:19+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'service.fluidsynth'
+ '';
+ }
+
+ {
+ time = "2020-06-17T22:17:52+00:00";
+ condition = config.programs.git.enable;
+ message = ''
+ Since May 1, 2020 string values in Git configurations are
+ automatically escaped. If you have any manually escaped characters,
+ then you may need to restore them to their unescaped form to avoid
+ double escaping.
+
+ In other words, if you now have something along the lines of
+
+ programs.git.aliases.hello = '''"!echo $'Hello\\nWorld'"''';
+
+ you must replace it by the unescaped form
+
+ programs.git.aliases.hello = "!echo $'Hello\nWorld'";
+
+ Apologies for the belated notification!
+ '';
+ }
+
+ {
+ time = "2020-06-23T20:06:39+00:00";
+ message = ''
+ A new module is available: 'programs.ne'
+ '';
+ }
+
+ {
+ time = "2020-07-24T15:03:11+00:00";
+ message = ''
+ A new module is available: 'programs.nushell'.
+ '';
+ }
+
+ {
+ time = "2020-07-25T21:04:59+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'services.dropbox'.
+ '';
+ }
+
+ {
+ time = "2020-08-13T22:15:27+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'programs.waybar'
+ '';
+ }
+
+ {
+ time = "2020-08-14T22:44:20+00:00";
+ condition = hostPlatform.isLinux;
+ message = ''
+ A new module is available: 'services.kanshi'
+ '';
+ }
+
+ {
+ time = "2020-08-25T22:14:01+00:00";
+ message = ''
+ A new module is available: 'programs.mcfly'
+ '';
+ }
+
+ {
+ time = "2020-09-01T18:38:18+00:00";
+ message = ''
+ A new module is available: 'programs.ncmpcpp'
+ '';
+ }
+
+ {
+ time = "2020-09-11T10:06:47+00:00";
+ condition = hostPlatform.isLinux && config.targets.genericLinux.enable;
+ message = ''
+ A new option 'targets.genericLinux.extraXdgDataDirs' is available
+ to setup the user environment with the OS's data files.
+
+ This is useful for example to get Bash completion for
+ 'systemctl' which shouldn't be installed through Home Manager.
+
+ This is also useful to have non Home Manager applications
+ available in menus.
+ '';
+ }
+
+ {
+ time = "2020-09-09T06:54:59+00:00";
+ condition = config.programs.man.enable;
+ message = ''
+ A new option 'programs.man.generateCaches' was added to
+ support the apropos command.
+ '';
+ }
];
};
}