aboutsummaryrefslogtreecommitdiff
path: root/home-manager/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/flake.nix')
-rw-r--r--home-manager/flake.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/home-manager/flake.nix b/home-manager/flake.nix
new file mode 100644
index 00000000000..2d53d603a61
--- /dev/null
+++ b/home-manager/flake.nix
@@ -0,0 +1,23 @@
+{
+ description = "Home Manager for Nix";
+
+ outputs = { self, nixpkgs }: rec {
+ nixosModules.home-manager = import ./nixos;
+
+ darwinModules.home-manager = import ./nix-darwin;
+
+ lib = {
+ homeManagerConfiguration = { configuration, system, homeDirectory
+ , username
+ , pkgs ? builtins.getAttr system nixpkgs.outputs.legacyPackages
+ , check ? true }@args:
+ import ./modules {
+ inherit pkgs check;
+ configuration = { ... }: {
+ imports = [ configuration ];
+ home = { inherit homeDirectory username; };
+ };
+ };
+ };
+ };
+}