aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 00000000000..697f66ac8e6
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,21 @@
+{
+ description = "Home Manager for Nix";
+
+ outputs = { self, nixpkgs }: rec {
+ nixosModules.home-manager = import ./nixos;
+
+ lib = {
+ homeManagerConfiguration = { configuration, system, homeDirectory
+ , username
+ , pkgs ? builtins.getAttr system nixpkgs.outputs.legacyPackages
+ , check ? true }@args:
+ import ./modules {
+ inherit pkgs check;
+ configuration = { ... }: {
+ imports = [ configuration ];
+ home = { inherit homeDirectory username; };
+ };
+ };
+ };
+ };
+}