aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/programs/ssh/forwards-local-bind-path-with-port-asserts.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /tests/modules/programs/ssh/forwards-local-bind-path-with-port-asserts.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to 'tests/modules/programs/ssh/forwards-local-bind-path-with-port-asserts.nix')
-rw-r--r--tests/modules/programs/ssh/forwards-local-bind-path-with-port-asserts.nix29
1 files changed, 13 insertions, 16 deletions
diff --git a/tests/modules/programs/ssh/forwards-local-bind-path-with-port-asserts.nix b/tests/modules/programs/ssh/forwards-local-bind-path-with-port-asserts.nix
index c05cba82791..f9d8e2daf85 100644
--- a/tests/modules/programs/ssh/forwards-local-bind-path-with-port-asserts.nix
+++ b/tests/modules/programs/ssh/forwards-local-bind-path-with-port-asserts.nix
@@ -8,29 +8,26 @@ with lib;
enable = true;
matchBlocks = {
localBindPathWithPort = {
- localForwards = [
- {
- # OK:
- host.address = "127.0.0.1";
- host.port = 3000;
+ localForwards = [{
+ # OK:
+ host.address = "127.0.0.1";
+ host.port = 3000;
- # Error:
- bind.address = "/run/user/1000/gnupg/S.gpg-agent.extra";
- bind.port = 3000;
- }
- ];
+ # Error:
+ bind.address = "/run/user/1000/gnupg/S.gpg-agent.extra";
+ bind.port = 3000;
+ }];
};
};
};
- home.file.result.text =
- builtins.toJSON
- (map (a: a.message)
- (filter (a: !a.assertion)
- config.assertions));
+ home.file.result.text = builtins.toJSON
+ (map (a: a.message) (filter (a: !a.assertion) config.assertions));
nmt.script = ''
- assertFileContent home-files/result ${./forwards-paths-with-ports-error.json}
+ assertFileContent home-files/result ${
+ ./forwards-paths-with-ports-error.json
+ }
'';
};
}