aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/programs/getmail/getmail.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-01-26 12:00:03 +0100
committerRobert Helgesson <robert@rycee.net>2020-01-26 21:11:23 +0100
commitde8033747c6b87a57869e2796155d2495770bbfd (patch)
tree3c24fe96135c6468945721c15dc4fcc34b189217 /tests/modules/programs/getmail/getmail.nix
parentfba87f899870c7c8fa412efeb2bcb6c31ac21e32 (diff)
tests: clean up tests
- Move all module tests to their own directories. - Avoid duplication of `// import`.
Diffstat (limited to 'tests/modules/programs/getmail/getmail.nix')
-rw-r--r--tests/modules/programs/getmail/getmail.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/modules/programs/getmail/getmail.nix b/tests/modules/programs/getmail/getmail.nix
new file mode 100644
index 00000000000..d72a8d6505a
--- /dev/null
+++ b/tests/modules/programs/getmail/getmail.nix
@@ -0,0 +1,29 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ imports = [ ../../accounts/email-test-accounts.nix ];
+
+ config = {
+ home.username = "hm-user";
+ home.homeDirectory = "/home/hm-user";
+
+ accounts.email.accounts = {
+ "hm@example.com" = {
+ getmail = {
+ enable = true;
+ mailboxes = ["INBOX" "Sent" "Work"];
+ destinationCommand = "/bin/maildrop";
+ delete = false;
+ };
+ imap.port = 993;
+ };
+ };
+
+ nmt.script = ''
+ assertFileExists home-files/.getmail/getmailhm@example.com
+ assertFileContent home-files/.getmail/getmailhm@example.com ${./getmail-expected.conf}
+ '';
+ };
+}