aboutsummaryrefslogtreecommitdiff
path: root/modules/xsession.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2018-07-24 12:48:53 +0200
committerRobert Helgesson <robert@rycee.net>2018-07-24 12:53:20 +0200
commit6ae2d74fca6d84303283f0594a329db7c5738067 (patch)
treea3a2fbf7fe47cd1cc298c112661a6929242ef605 /modules/xsession.nix
parent29ad012763f4e07c5c50635915c1d4ae751123cc (diff)
xsession: add option `preferStatusNotifierItems`
The intent is for tray applets to honor this option if they support the SNI protocol.
Diffstat (limited to 'modules/xsession.nix')
-rw-r--r--modules/xsession.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/xsession.nix b/modules/xsession.nix
index 3bce4506521..816a1aa9fbd 100644
--- a/modules/xsession.nix
+++ b/modules/xsession.nix
@@ -30,6 +30,17 @@ in
'';
};
+ preferStatusNotifierItems = mkOption {
+ type = types.bool;
+ default = false;
+ example = true;
+ description = ''
+ Whether tray applets should prefer using the Status Notifier
+ Items (SNI) protocol, commonly called App Indicators. Note,
+ not all tray applets or status bars support SNI.
+ '';
+ };
+
profileExtra = mkOption {
type = types.lines;
default = "";